const regex = new RegExp('^-?[0-9]+(?:\\.[0-9]+)?(?:(?:e|E)(?:-|\\+)?[0-9]+)?$', 'gm')
const str = `100
-100
12.34
4e10
4.2e-2
9e+5
1.2.3
v100
10.
.01`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}