re = /^-?[0-9]+(?:\.[0-9]+)?(?:(?:e|E)(?:-|\+)?[0-9]+)?$/m
str = '100
-100
12.34
4e10
4.2e-2
9e+5
1.2.3
v100
10.
.01'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end