package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ix)(?:
\s[abcd](?:[0-9][a-z0-9]{3}|[0-9o][0-9o)][0-9][0-9a-z]|[0-9o][0-9a-z)][0-9a-z][0-9])
|
[^a-z0-9][abcd]\s[0-9][0-9a-z]{3}
)(?!\S)`)
var str = ` A0ABC B0ABC `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}