$re = '/(?:
\s[abcd](?:[0-9][a-z0-9]{3}|[0-9o][0-9o)][0-9][0-9a-z]|[0-9o][0-9a-z)][0-9a-z][0-9])
|
[^a-z0-9][abcd]\s[0-9][0-9a-z]{3}
)(?!\S)/ix';
$str = ' A0ABC B0ABC ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);