const regex = /(?:
\s[abcd](?:[0-9][a-z0-9]{3}|[0-9o][0-9o)][0-9][0-9a-z]|[0-9o][0-9a-z)][0-9a-z][0-9])
|
[^a-z0-9][abcd]\s[0-9][0-9a-z]{3}
)(?!\S)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:
\\s[abcd](?:[0-9][a-z0-9]{3}|[0-9o][0-9o)][0-9][0-9a-z]|[0-9o][0-9a-z)][0-9a-z][0-9])
|
[^a-z0-9][abcd]\\s[0-9][0-9a-z]{3}
)(?!\\S)', 'gi')
const str = ` A0ABC B0ABC `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}