using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"favourites\/([0-9]+)\/([0-9]+)\/([0-9]+)";
string input = @"www.site.ru/favourites/19/31/56/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}