re = /favourites\/([0-9]+)\/([0-9]+)\/([0-9]+)/m
str = 'www.site.ru/favourites/19/31/56/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end