$re = '/favourites\/([0-9]+)\/([0-9]+)\/([0-9]+)/m';
$str = 'www.site.ru/favourites/19/31/56/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);