#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(_)([^_]+)(\..{3})$"
Local $sString = "windows10.0-kb4485448-x64_e43307ad84b7df662be562eafc70e0b081dffc38.msu" & @CRLF & _
"windows10.0-kb4487017-x64_delta_0718751eb60b786cda40725bda3e09e26374d83c.msu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")