import re
regex = re.compile(r"(_)([^_]+)(\..{3})$", flags=re.MULTILINE)
test_str = ("windows10.0-kb4485448-x64_e43307ad84b7df662be562eafc70e0b081dffc38.msu\n"
"windows10.0-kb4487017-x64_delta_0718751eb60b786cda40725bda3e09e26374d83c.msu")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")