# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=(["']\b))(?:(?=(\\?))\2.)*?(?=\1)/Subbed/g;t' <<< "Hello Colm \"This is a test\"
\"This is also an NL test\"
'And this has an escaped quote don\'t in it ' Blue Boy
\"This has a single quote ' but doesn\' end the quote as it started with double quotes\"
\"Foo Bar\" \"Another Value\" something else
\"1 string\" \" 2 string with space\" '3 string no space'"