using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=([""']\b))(?:(?=(\\?))\2.)*?(?=\1)";
string substitution = @"Subbed";
string input = @"Hello Colm ""This is a test""
""This is also an NL test""
'And this has an escaped quote don\'t in it ' Blue Boy
""This has a single quote ' but doesn\' end the quote as it started with double quotes""
""Foo Bar"" ""Another Value"" something else
""1 string"" "" 2 string with space"" '3 string no space'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}