re = /(?<=(["']\b))(?:(?=(\\?))\2.)*?(?=\1)/
str = 'Hello Colm "This is a test"
"This is also an NL test"
\'And this has an escaped quote don\\\'t in it \' Blue Boy
"This has a single quote \' but doesn\\\' end the quote as it started with double quotes"
"Foo Bar" "Another Value" something else
"1 string" " 2 string with space" \'3 string no space\''
subst = 'Subbed'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result