#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(19|20)\d{2}(?:-(?:0[1-9]|1[0-2])(?:-(?:0[1-9]|[12][0-9]|3[01]))?)?$"
Local $sString = "1921-00" & @CRLF & _
"1921-" & @CRLF & _
"1921-1" & @CRLF & _
"192-22" & @CRLF & _
"2009" & @CRLF & _
"2009-12" & @CRLF & _
"2009-13" & @CRLF & _
"1921-5-4" & @CRLF & _
"1899-12-31" & @CRLF & _
"1900-01-01" & @CRLF & _
"2099-12-31" & @CRLF & _
"2100-01-01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")