package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(19|20)\d{2}(?:-(?:0[1-9]|1[0-2])(?:-(?:0[1-9]|[12][0-9]|3[01]))?)?$`)
var str = `1921-00
1921-
1921-1
192-22
2009
2009-12
2009-13
1921-5-4
1899-12-31
1900-01-01
2099-12-31
2100-01-01`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}