import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(19|20)\\d{2}(?:-(?:0[1-9]|1[0-2])(?:-(?:0[1-9]|[12][0-9]|3[01]))?)?$";
final String string = "1921-00\n"
+ "1921-\n"
+ "1921-1\n"
+ "192-22\n"
+ "2009\n"
+ "2009-12\n"
+ "2009-13\n"
+ "1921-5-4\n"
+ "1899-12-31\n"
+ "1900-01-01\n"
+ "2099-12-31\n"
+ "2100-01-01";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}