package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z0-9.]+.com)`)
var str = `From:mail.usn.tn.com , Transporder via: exo2.reg.nt.com , fj.ter.usa`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}