re = /([a-z0-9.]+.com)/m
str = 'From:mail.usn.tn.com , Transporder via: exo2.reg.nt.com , fj.ter.usa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end