$re = '/([a-z0-9.]+.com)/m';
$str = 'From:mail.usn.tn.com , Transporder via: exo2.reg.nt.com , fj.ter.usa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);