using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)name";
string substitution = @"$1baby";
string input = @"My name is Bob, her name is Sara.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}