use strict;
my $str = 'My name is Bob, her name is Sara.';
my $regex = qr/^(.*?)name/p;
my $subst = '$1baby';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";