$re = '/^(.*?)name/';
$str = 'My name is Bob, her name is Sara.';
$subst = "$1baby";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;