package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\s*(.*?)\s*)(?:#.*)`)
var str = `test1 #comments1
test 2 blah #comments2
test3 4
923423423 #comments3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}