// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\s*(.*?)\s*)(?:#.*)").unwrap();
let string = "test1 #comments1
test 2 blah #comments2
test3 4
923423423 #comments3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}