$re = '/(?:\s*(.*?)\s*)(?:#.*)/m';
$str = 'test1 #comments1
test 2 blah #comments2
test3 4
923423423 #comments3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);