package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@[A-Za-z][A-Za-z0-9]*(?:_[A-Za-z0-9]+)*`)
var str = `@username @username_ @user_name`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}