re = /@[A-Za-z][A-Za-z0-9]*(?:_[A-Za-z0-9]+)*/
str = '@username @username_ @user_name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end