$re = '/@[A-Za-z][A-Za-z0-9]*(?:_[A-Za-z0-9]+)*/';
$str = '@username @username_ @user_name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);