package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([1-9]|([012][0-9])|(3[01]))\/([0]{0,1}[1-9]|1[012])\/\d\d\d\d [012]{0,1}[0-9]:[0-6][0-9]$`)
var str = `01/03/2010 23:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}