const regex = /^([1-9]|([012][0-9])|(3[01]))\/([0]{0,1}[1-9]|1[012])\/\d\d\d\d [012]{0,1}[0-9]:[0-6][0-9]$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9]|([012][0-9])|(3[01]))\\\/([0]{0,1}[1-9]|1[012])\\\/\\d\\d\\d\\d [012]{0,1}[0-9]:[0-6][0-9]$', 'g')
const str = `01/03/2010 23:00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}