re = /^([1-9]|([012][0-9])|(3[01]))\/([0]{0,1}[1-9]|1[012])\/\d\d\d\d [012]{0,1}[0-9]:[0-6][0-9]$/
str = '01/03/2010 23:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end