#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!^[0-9])(?![0-9][AZ])(?![AZ0-9*]*\*\*)(?![AZ0-9*]*\*[AZ])((?=[AZ0-9]{6})|(?=[AZ0-9*]*\*))(?![AZ0-9*]*[0-9][A-Z])[AZ0-9*]{1,6}$"
Local $sString = "^(?![0-9])(?![0-9][AZ])(?![AZ0-9*]*\*\*)(?![AZ0-9*]*\*[AZ0])(?=[AZ0-9*]*\*)(?![AZ0-9*]*[0-9][A-Z])[AZ0-9*]{1,6}$" & @CRLF & _
"Broken down: " & @CRLF & _
"^(?![0-9])" & @CRLF & _
"(?![0-9][AZ])" & @CRLF & _
"(?![AZ0-9*]*\*\*)" & @CRLF & _
"(?![AZ0-9*]*\*[AZ0])" & @CRLF & _
"(?=[AZ0-9*]*\*)" & @CRLF & _
"(?![AZ0-9*]*[0-9][A-Z])" & @CRLF & _
"[AZ0-9*]{1,6}$" & @CRLF & _
"" & @CRLF & _
"Check these for patterns" & @CRLF & _
"Following would be valid" & @CRLF & _
"*" & @CRLF & _
"*1" & @CRLF & _
"*1*" & @CRLF & _
"*12345" & @CRLF & _
"A*" & @CRLF & _
"A*2" & @CRLF & _
"A*2*" & @CRLF & _
"A1*3" & @CRLF & _
"A1*3*" & @CRLF & _
"A12*4" & @CRLF & _
"A*2" & @CRLF & _
"A*23" & @CRLF & _
"A*234" & @CRLF & _
"A*2345" & @CRLF & _
"A12*45" & @CRLF & _
"A1234*" & @CRLF & _
"A*2345" & @CRLF & _
"A12*4*" & @CRLF & _
"A*23*5" & @CRLF & _
"A123*5" & @CRLF & _
"*12345" & @CRLF & _
"*1234*" & @CRLF & _
"*1*3*5" & @CRLF & _
"*12*4*" & @CRLF & _
"*1*3*5" & @CRLF & _
"*123*5" & @CRLF & _
"A12345" & @CRLF & _
"" & @CRLF & _
"Examples of invalid entries: <Any ** entry> - <Any * A-Z character> - <Any value longer than 6>" & @CRLF & _
"A1" & @CRLF & _
"A12" & @CRLF & _
"A123" & @CRLF & _
"A1234" & @CRLF & _
"*A1234" & @CRLF & _
"B*" & @CRLF & _
"B1*" & @CRLF & _
"BA*45" & @CRLF & _
"B*2345" & @CRLF & _
"**" & @CRLF & _
"*1A" & @CRLF & _
"*1A1*" & @CRLF & _
"*A2345" & @CRLF & _
"*123456" & @CRLF & _
"1234*" & @CRLF & _
"A" & @CRLF & _
"**12" & @CRLF & _
"*1**" & @CRLF & _
"*1*3**" & @CRLF & _
"*12**" & @CRLF & _
"*1*3*56" & @CRLF & _
"*123**" & @CRLF & _
"*12*45*" & @CRLF & _
"A*23456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")