import re
regex = re.compile(r"\d{3}(\.)?\d{3}\1\d{3}-\d+", flags=re.MULTILINE)
test_str = ("CPFs:\n"
" - 345.679.411-64\n"
" - 555.984.452-33")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")