# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\$)/const $ = require('jquery');\n$1/g;t' <<< "$(document).ready(function () {
$('.btn-toggle-achievement').on('click', function (e) {
var button = e.target;
var el = $(button);
$.post('/achievements_ajax/toggle_achievement', {
status: el.data('enable'),
achievement_id: el.data('achievement-id')
});
});
});"