import Foundation
let pattern = #"(\$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
$(document).ready(function () {
$('.btn-toggle-achievement').on('click', function (e) {
var button = e.target;
var el = $(button);
$.post('/achievements_ajax/toggle_achievement', {
status: el.data('enable'),
achievement_id: el.data('achievement-id')
});
});
});
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"const $ = require('jquery');\n$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)