const regex = /(\$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\$)', 'g')
const str = `\$(document).ready(function () {
\$('.btn-toggle-achievement').on('click', function (e) {
var button = e.target;
var el = \$(button);
\$.post('/achievements_ajax/toggle_achievement', {
status: el.data('enable'),
achievement_id: el.data('achievement-id')
});
});
});`;
const subst = `const $ = require('jquery');\n$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);