using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\n(?!(([^""\\]*(?:\\.[^""\\]*)*""\n)|[^`\\]*(?:\\.[^`\\]*)*`\n))";
string input = @"\nnew""test\naaaa""\nta\n`this is a \nnewline that should be kept`";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}