$re = '/\\\\n(?!(([^"\\\\]*(?:\\\\.[^"\\\\]*)*"\n)|[^`\\\\]*(?:\\\\.[^`\\\\]*)*`\n))/';
$str = '\\nnew"test\\naaaa"\\nta\\n`this is a \\nnewline that should be kept`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);