re = /\\n(?!(([^"\\]*(?:\\.[^"\\]*)*"\n)|[^`\\]*(?:\\.[^`\\]*)*`\n))/
str = '\\nnew"test\\naaaa"\\nta\\n`this is a \\nnewline that should be kept`'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end