import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(ds)|ksn-(?:a-(?:stat|p2p)|(?:file|verdict|url|c?info))-geo)\\.kaspersky(?(1)|-labs)\\.com$";
final String string = "ds.kaspersky.com\n"
+ "ksn-a-stat-geo.kaspersky-labs.com\n"
+ "ksn-a-p2p-geo.kaspersky-labs.com\n"
+ "ksn-file-geo.kaspersky-labs.com\n"
+ "ksn-verdict-geo.kaspersky-labs.com\n"
+ "ksn-url-geo.kaspersky-labs.com\n"
+ "ksn-info-geo.kaspersky-labs.com\n"
+ "ksn-cinfo-geo.kaspersky-labs.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}