const regex = /^(?:(ds)|ksn-(?:a-(?:stat|p2p)|(?:file|verdict|url|c?info))-geo)\.kaspersky(?(1)|-labs)\.com$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(ds)|ksn-(?:a-(?:stat|p2p)|(?:file|verdict|url|c?info))-geo)\\.kaspersky(?(1)|-labs)\\.com$', 'gmi')
const str = `ds.kaspersky.com
ksn-a-stat-geo.kaspersky-labs.com
ksn-a-p2p-geo.kaspersky-labs.com
ksn-file-geo.kaspersky-labs.com
ksn-verdict-geo.kaspersky-labs.com
ksn-url-geo.kaspersky-labs.com
ksn-info-geo.kaspersky-labs.com
ksn-cinfo-geo.kaspersky-labs.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}