$re = '/^(?:(ds)|ksn-(?:a-(?:stat|p2p)|(?:file|verdict|url|c?info))-geo)\.kaspersky(?(1)|-labs)\.com$/mi';
$str = 'ds.kaspersky.com
ksn-a-stat-geo.kaspersky-labs.com
ksn-a-p2p-geo.kaspersky-labs.com
ksn-file-geo.kaspersky-labs.com
ksn-verdict-geo.kaspersky-labs.com
ksn-url-geo.kaspersky-labs.com
ksn-info-geo.kaspersky-labs.com
ksn-cinfo-geo.kaspersky-labs.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);