re = /(\d+(?:[.,]\d+)?)/m
str = 'Есть стринга типа \'asda12312.234234ertert,34534\'. Нужно достать из неё только цифры ипервую точку или запятую.
\'asda12312.234234ertert,34534\' => \'12312.23423434534\'
\'asda12312,234234ertert,34534\' => \'12312,23423434534\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end