package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)"Living Room"\s*\[(.*?)]`)
var str = `"Living Room" [62AD]
Hub "Living Room" [21BC]:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}