$re = '~"Living Room"\s*\[(.*?)]~im';
$str = '"Living Room" [62AD]
Hub "Living Room" [21BC]:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);