re = /"Living Room"\s*\[(.*?)]/im
str = '"Living Room" [62AD]
Hub "Living Room" [21BC]:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end