#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(.*\.)(jpe?g|gif|docx?|pdf)$"
Local $sString = "any_file_name_we_wish_here_with_!@#$%^&*_1234567.jpg" & @CRLF & _
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.jpeg" & @CRLF & _
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.JPG" & @CRLF & _
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.docx" & @CRLF & _
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.doc" & @CRLF & _
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.pdf" & @CRLF & _
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.gif" & @CRLF & _
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.mp3" & @CRLF & _
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.mp4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")