import re
regex = re.compile(r"(.*\.)(jpe?g|gif|docx?|pdf)$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("any_file_name_we_wish_here_with_!@#$%^&*_1234567.jpg\n"
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.jpeg\n"
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.JPG\n"
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.docx\n"
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.doc\n"
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.pdf\n"
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.gif\n"
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.mp3\n"
"any_file_name_we_wish_here_with_!@#$%^&*_1234567.mp4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")