import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*\\.)(jpe?g|gif|docx?|pdf)$";
final String string = "any_file_name_we_wish_here_with_!@#$%^&*_1234567.jpg\n"
+ "any_file_name_we_wish_here_with_!@#$%^&*_1234567.jpeg\n"
+ "any_file_name_we_wish_here_with_!@#$%^&*_1234567.JPG\n"
+ "any_file_name_we_wish_here_with_!@#$%^&*_1234567.docx\n"
+ "any_file_name_we_wish_here_with_!@#$%^&*_1234567.doc\n"
+ "any_file_name_we_wish_here_with_!@#$%^&*_1234567.pdf\n"
+ "any_file_name_we_wish_here_with_!@#$%^&*_1234567.gif\n"
+ "any_file_name_we_wish_here_with_!@#$%^&*_1234567.mp3\n"
+ "any_file_name_we_wish_here_with_!@#$%^&*_1234567.mp4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}