const regex = /\d+(?!\D)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(?!\\D)', 'gm')
const str = `1text
text5
who is 1st here
1990 2000 3000
numbers 4
3.141`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}